From: me@... Date: 2015-10-27T23:00:35+00:00 Subject: [ruby-core:71233] [CommonRuby - Feature #11627] [Open] make `nonzero` an alias of `nonzero?` Issue #11627 has been reported by Dan Sherson. ---------------------------------------- Feature #11627: make `nonzero` an alias of `nonzero?` https://bugs.ruby-lang.org/issues/11627 * Author: Dan Sherson * Status: Open * Priority: Normal * Assignee: ---------------------------------------- for historic reasons `nonzero?` returns self or nil. (according to https://bugs.ruby-lang.org/issues/9123) I like the expectation that `method?` returns true and false. That `nonzero?` returns only truthy/falsy values would be fine, except using its return values are _useful_. `value.nonzero? || calculation` or `(a <=> b).nonzero? || a.subvalue <=> b.subvalue` I would feel more comfortable with `value.nonzero || calculation` even though it is only one character different. Yes, it's a small thing, but I like ruby for the small things :) Thanks. -- https://bugs.ruby-lang.org/